Should you consider Apache 2.0 for an Oracle APEX installation?

Just read a very interesting posting by Joel Kallman, titled Oracle HTTP Server, Apache 2.0 and connection pooling. Before Oracle 11g, mod_plsql was just available for Apache 1.3 which had one big drawback on Unix systems. Apache 1.3 just supports a process model which prevents that mod_plsql can really take use of a database connection pool, because each process has his own “dedicated” database session which can’t be shared across process bounders.

Continue reading