ApexLib 1.7 released!

Unbelievable, but I finally found the time to put together a new release of the ApexLib Framework for Oracle Application Express (APEX).

I have created bug fixes and enhancements since the last version has been released last year, but I just sent them to the person who requested it. I thought it’s really getting time to put together a up-to-date version which also handles some issues with the last Oracle APEX 3.1.1 patchset.

The new version contains some new features, trimming blanks from submitted page items and tabular form columns is one of them. To disable the feature use $APEXLIB_NO_TRIM$

I have also updated the installation and integration documentation to the new style of the web page. See the change log for a full documentation of change requests and bug fixes. The upgrade instructions can also be found in the change log.

Download version 1.7!

BTW, don’t forget to download and install the integration files for the Oracle APEX Builder Plugin to get a seamless integration of the ApexLib settings into your APEX Builder development environment.

Have fun using the framework!

Note: Version 1.7 will probably be the last version which supports Oracle APEX 2.2

9 thoughts on “ApexLib 1.7 released!

  1. Hi Patrick,
    I am trying to download Apexlib 1.7 but all the download links are going to version 1.6, also i have searched Sourceforge and i couldn’t find 1.7. Have removed this version from Souceforge if not can you plz give me link to download 1.7

    Thanks

  2. Patrick,

    Please update your sourceforge website to include 1.7, I was frustrated to find trimcolumns not in the Packages.

    Pretty frustrating to use when developing and for the life of me knowing the install is corrupted.

    Cheers

  3. Patrick,

    What’s up with this? Sourceforge still only has 1.6.

    Thanks,

    Stew

  4. Um. Same here. Is 1.7 anywhere?

    (And does it work with Firefor 3/IE 7-8?)

  5. Do I need to reinstall apexlib after upgrade from apex 3.1 to 3.2.1 ?

    Because some of my cascading LOV are not work after upgrading.
    thank you very much!

    Kasom

  6. Stew –

    Clicking the link you gave takes me to a page where there’s 1.6, but the message:

    “The “ApexLib_v1_7.zip” file could not be found or is not available. Please select another file”

    appears on the top of the page. So it doesn’t seem to work (at least for me :))

  7. From the source code you all can download the needed code – This isn’t a project where you need to be expert to compile, you just have to be capable of running a microsoft bat file – thus have access to a windows computer.

    See: http://apexlib.svn.sourceforge.net/viewvc/apexlib/tags/v1_7/

    1. Hit the “Download GNU tarball” link.
    2. Unpack the tarball
    3. Run the create_deployment.bat file
    4. Treate the deploy directory as the result of a new standard download
    5. Follow install instructions as provided on the website.

    Happy coding

Comments are closed.